Qt 5.9 は LTS になります

Published Monday May 29th, 2017
Leave a comment
Posted in Qt | Tags: ,

この記事は The Qt BlogIntroducing Long Term Support for Qt 5.9 を翻訳したものです。
執筆: Tuukka Turunen, 2017年5月11日

Qt 5.9 を Long Term Support(LTS) とすることをこの度決定いたしました。Qt 5.6 LTS 以降、様々な改善がなされて来ており、それらの恩恵をユーザーのみなさんが最大限活用できるよう、Qt 5.9 を LTS とすることにしました。Qt 5.9 の正式リリース以降の3年間、Qt 5.9.x というパッチリリースを継続して行う予定です(Qt 5.10 のリリース以降も 5.9.x のサポートは継続されます)。商用版をお使いの方は、LTS の期間内は 5.9 のサポートを受け続けることができます。

前回の LTS である Qt 5.6 のリリース以来、数え切れないほどの改善がなされてきました。大幅なパフォーマンスの改善やいくつもの新機能の追加、膨大な数のバグの修正が行われています。Qt 5.9 LTS は Qt 5.6 LTS 以降の大幅な改善を取り込んだ最高の製品になるでしょう。というわけで、すべてのユーザーのみなさんが、これまでの成果を享受できるよう、Qt 5.9 を LTS といたしました

Qt 5.6 LTS と同様、Qt 5.9 LTS のパッチレベルリリースはいくつかのフェーズに分けるアプローチを取ります。リリース日以降、最初の6ヶ月は優先度の低いものも含めて多くのバグの修正が行われる予定です。その後 LTS リリースとしては「strict」フェーズに移行し、致命的なバグの修正やセキュリティの対応のみが行われるようになります。これにより LTS リリースの安定性を保証します。LTS の最後の一年間は「very strict」モードとなり、致命的なセキュリティのみの対応となります。

今後はじめられるプロジェクトでは、Qt 5.9 LTS を強く推奨します。まもなくリリース予定の Qt 5.9 LTS は一つ前の古い C++98 準拠のコンパイラでも利用可能な Qt 5.6 LTS と平行してサポートされます。Qt 5.9 LTS には Qt 5.6 LTS 以降に行われた様々なパフォーマンスの改善やそれ以外の改善、バグの修正が含まれます。現在 Qt 5.6 LTS は「strict」フェーズのため、致命的なバグ以外の対応は今後はなされず、まもなく「very strict」フェーズに移行します。その後は重要なセキュリティの修正のみの対応となります。

Qt の LTS のポリシーでは、Qt 5.9 LTS のリリースは標準で3年サポートされることになっており、その後も延長サポートが購入可能になるでしょう。サポート期間内は、次のバージョンのリリース(5.10 以降)があっても Qt 5.9 LTS に対するバグ修正やセキュリティ対策のパッチリリースが継続されます。LTS リリースに関しては、LTS ではないリリースよりもパッチリリースの数は多くなり、LTS の期間内は当然これは継続されます。パッチリリースでは、セキュリティ対策やエラーの訂正、改善以外にも、必要に応じて新しい OS やコンパイラ(の新しいバージョン)の対応なども行われる可能性があります。また、「非推奨」のモジュールやテクノロジープレビューのモジュールは LTS の範囲外になります。

Qt 5.9 ベータ版はすでにオンラインインストーラー経由で入手可能ですので、是非この機会にお試しください。Qt のオンラインインストーラーをまだお使いでない方は、Qt Account のページもしくは Qt のダウンロード から入手してください。現在 2017年5月末 を目標に Qt 5.9.0 のリリースに向けた作業を行っています。お楽しみに。

Do you like this? Share it
Share on LinkedInGoogle+Share on FacebookTweet about this on Twitter

Posted in Qt | Tags: ,

Leave a Reply

Your email address will not be published.

Get started today with Qt Download now